Network failure using Swoosh

I am trying to use swoosh for emailing. I have basically followed the steps in Swoosh.Mailer — Swoosh v1.3.5.

My config looks like:

config :bw, Bw.Mailer,
  adapter: Swoosh.Adapters.SMTP,
  relay: "smtp.gmail.com",
  username: System.get_env("BW_MAIL_USERNAME"), # gmail username
  password: System.get_env("BW_MAIL_PASSWORD"), # gmail password
  ssl: true,
  tls: :always,
  auth: :always,
  port: 1025,
  retries: 2,
  no_mx_lookups: false

I have created an email struct, but when I try to deliver it, I get:

> Bw.Mailer.deliver(email)
{:error, {:retries_exceeded, {:network_failure, '108.177.126.109', {:error, :timeout}}}}

I have no idea where the error could be. Is it in my configuration? Any help is appreciated.

1 Like

Have you tried manually invoking the API through curl and check if you get a similar error?

Thanks for the suggestion! Just tried to send an email by curl, and that works.
Any idea how to debug this?

As a start, use curl like this: curl -iv ..., that way you’ll see both request and response headers.

Then, you can try and see which headers does swoosh use when sending the request. In the ideal case it’ll have a way for you to control them. And then try to equalize what you’ve seen on the CLI with curl and what your Elixir code does.

You sure the port 1025 is correct? Usually SMTP with STARTTLS is on port 587, ans SSL SMTP is on 465.

Also, Gmail SMTP is supposed to be used by interactive clients, not a backend server. They may have some rule based filtering and limiting that hinder your usage. I 'd stick to one of the following:

  • Sendgrid, etc, 100 mails per day in the free tier
  • Amazon SES. If you are sending a lot
  • Your own SMTP server
1 Like

Thanks! Yes, the port was wrong, among other things. I had just copied it from an example, I did not realize I had to change it to a specific value.
It had to change the port to 465, and set tls: if_available. Port 587 did not work though.
Besides that, I found out that, despite what the Swoosh doc suggests, that the emails must have a text_body.
Now the emails are working.

And yes, I will move to some other SMTP server, I just wanted to do a few tests using my gmail account. Thanks for the suggestions!

Working settings for Gmail (port 587)

config :sample, Sample.Mailer,
  adapter: Swoosh.Adapters.SMTP,
  relay: "smtp.gmail.com",
  username: "name@gmail.com",
  password: "apppassword",
  ssl: false,
  tls: :always,
  auth: :always,
  port: 587,
  retries: 2

Requirements for Gmail:

  1. Set up 2-Step Verification
  2. Generate app password
  3. Switch off your VPN (if you’re testing on localhost)