Strange error , unable to trace the source

I have no idea where this may be coming from

Erlang/OTP 26 [erts-14.1.1] [source] [64-bit] [smp:20:20] [ds:20:20:10] [async-threads:1] [jit:ns]

Interactive Elixir (1.15.7) - press Ctrl+C to exit (type h() ENTER for help)

13:25:07.092 [error] Process :user_drv_reader (#PID<0.68.0>) terminating
** (CaseClauseError) no case clause matching: {:error, {:GetOverlappedResult, :"The I/O operation has been aborted because of either a thread exit or an application request.\r\n"}}
    (kernel 9.1) prim_tty.erl:476: :prim_tty.reader_loop/6
    (stdlib 5.1.1) proc_lib.erl:241: :proc_lib.init_p_do_apply/3
Initial Call: :prim_tty.reader/1
Ancestors: [:user_drv, #PID<0.64.0>, :kernel_sup, #PID<0.47.0>]

my environment

λ elixir --version
Erlang/OTP 26 [erts-14.1.1] [source] [64-bit] [smp:20:20] [ds:20:20:10] [async-threads:1] [jit:ns]

Elixir 1.15.7 (compiled with Erlang/OTP 26)

My deps:

  defp deps do
      {:decimal, "~> 2.0", override: true},
      {:excoding, "~> 0.1"},
      {:fs, "~> 6.12"},
      {:jason, "~> 1.2"},
      {:req, "~> 0.4.3"},
      {:tds, github: "elixir-ecto/tds"},
      {:xler, path: "../xler"}

A few quick questions:

  1. Does this happen when you do iex or does it require iex -S mix
  2. Have you done an rm -rf _build deps sanity check yet?

What I have tried to remedy:

1. manually delete `deps` and `_build`
2. mix deps.update --all
3. mix compile --force

same error


iex -S mix

There is a similar issue mentioned here: user_drv_reader terminating · Issue #13016 · elixir-lang/elixir · GitHub

1 Like

Optionally, you can see if OTP 25 works. To eliminate any code you can also try to just run iex or erl outside of your project to make sure those start without problems.

Started working after a system restart,
Then stopped working again