Release build failing with undefined function erlang:get_stacktrace/0 after OTP 24 update

I have a Docker image that I use to compile my releases for deployment, I recently updated it to use OTP 24 and the latest Elixir version (1.12.0).

After making that change, now my release builds always fail with the following error:

$ MIX_ENV=prod mix release
===> Fetching rebar3_hex v6.11.4
===> Downloaded package, caching at /home/sezdocs/.cache/rebar3/hex/hexpm/packages/rebar3_hex-6.11.4.tar
escript: exception error: undefined function erlang:get_stacktrace/0
  in function  rebar3:main/1 (/rebar3/src/rebar3.erl, line 72)
  in call from escript:run/2 (escript.erl, line 750)
  in call from escript:start/1 (escript.erl, line 277)
  in call from init:start_em/1 
  in call from init:do_boot/3 
** (Mix) Could not compile dependency :sleeplocks, "/home/sezdocs/.mix/rebar3 bare compile --paths /home/sezdocs/project/endpoints/_build/prod/lib/*/ebin" command failed. You can recompile this dependency with "mix deps.compile sleeplocks", update it with "mix deps.update sleeplocks" or clean it with "mix deps.clean sleeplocks"

Does anyone knows why is this happening and how to solve it?

Also, I don’t know if this helps, but here is my Dockerfile:

FROM ubuntu:20.04 AS build

ARG USER=builder
ARG UID=1000
ARG GID=1000
ARG PWD=builder

RUN apt-get update
RUN DEBIAN_FRONTEND=noninteractive apt-get install -y apt-transport-https ca-certificates gnupg software-properties-common wget

RUN wget -O - 2> /dev/null | gpg --dearmor - | tee /etc/apt/trusted.gpg.d/kitware.gpg > /dev/null

RUN apt-add-repository 'deb focal main'

RUN wget -O - | apt-key add -

RUN apt-add-repository 'deb llvm-toolchain-focal-12 main'

RUN apt-get update

RUN DEBIAN_FRONTEND=noninteractive apt-get -y dist-upgrade

RUN DEBIAN_FRONTEND=noninteractive apt-get install -y apt-utils

RUN wget
RUN dpkg -i erlang-solutions_2.0_all.deb
RUN rm erlang-solutions_2.0_all.deb

RUN apt-get update

RUN DEBIAN_FRONTEND=noninteractive apt-get install -y esl-erlang
RUN DEBIAN_FRONTEND=noninteractive apt-get install -y elixir

RUN DEBIAN_FRONTEND=noninteractive apt-get install -y clang-12 capnproto

RUN DEBIAN_FRONTEND=noninteractive apt-get install -y git

RUN DEBIAN_FRONTEND=noninteractive apt-get install -y cmake

RUN DEBIAN_FRONTEND=noninteractive apt-get install -y curl

RUN update-alternatives --install /usr/bin/cc cc /usr/bin/clang-12 10
RUN update-alternatives --install /usr/bin/c++ c++ /usr/bin/clang++-12 10

RUN useradd -m $USER --uid $UID
RUN echo "${USER}:${PWD}" | chpasswd



ENV TERM=xterm-256color

RUN curl -sSf | bash -s -- -y

RUN echo 'source $HOME/.cargo/env' >> ~/.bashrc

RUN echo 'PS1="(builder) $PS1"' >> ~/.bashrc

RUN mix local.hex --force
RUN mix local.rebar --force

WORKDIR /home/${USER}/project

CMD ["/bin/bash"]

I build it with:

docker build --build-arg USER=$USER   \
             --build-arg UID=$(id -u) \
             --build-arg GID=$(id -g) \
             --no-cache               \
             -t tip-off/builder:v1 . 

and run it with:

docker run --detach-keys='ctrl-e,e' -it -v$(pwd):/home/$USER/project --rm tip-off/builder:v1

I found out that the dependency using sleeplocks (which seems to trigger the issue) is Cachex, and found this github issue there: Cachex (-> Sleeplocks) not working on Elixir 1.12.1 · Issue #274 · whitfin/cachex · GitHub

Still, I don’t understand what is triggering it.

What version of Erlang was Elixir compiled under? If you run elixir --version you should get output like Elixir 1.12.1 (compiled with Erlang/OTP 23)

I wonder if your issue could be similar to: Prevent crash in Erlang/OTP 24 (upcoming) by paulo-ferraz-oliveira · Pull Request #2361 · erlang/rebar3 · GitHub

Yeah, this is not required. Sorry about wasting your time. Compiled rebar3 with Erlang/OTP 19 and tried to use it with Erlang/OTP 23.

Or maybe it’s some sort of docker issue (which I wouldn’t be able to help with)

Mine shows Elixir 1.12.0 (compiled with Erlang/OTP 24).

Ok, I was able to fix this changing my HEX_MIRROR for some reason.

What I did was:

HEX_MIRROR= mix local.hex
HEX_MIRROR= mix local.rebar
1 Like

Just an update, in the end the error was a regression in hex servers, José Valim already fixed it Compilation fails with undefined function erlang:get_stacktrace/0 · Issue #11047 · elixir-lang/elixir · GitHub :smiley: