Ecto, Contexts and Naming References

Hello there,
My first post here.

I am playing out with Elixir and the new Phoenix (1.3). Tried to create a Todo app following the code snippets here: http://blog.plataformatec.com.br/2015/08/working-with-ecto-associations-and-embeds/

Since it is Phoenix 1.3, I tried to put them into context. However, naming seems to be confusing.

I created the project as follows:

mix phx.gen.html Todo List lists title:string

mix phx.gen.schema Todo.Item items body:text list_id:references:lists

scheme are as follows:

schema "todo_lists" do
    field :title, :string
		has_many :todo_items, TodoApp.Todo.Item

    timestamps()
  end 

 schema "todo_items" do
    field :body, :string
    #field :todo_list_id, :id
		belongs_to :todo_list, TodoApp.Todo.List
		
    timestamps()
  end

I receive this error:

Ecto.QueryError at GET /lists/4
deps/ecto/lib/ecto/association.ex:495: field TodoApp.Todo.Item.list_id in where does not exist in the schema in query:

from i in TodoApp.Todo.Item,
where: i.list_id == ^4,
order_by: [asc: i.list_id],
select: {i.list_id, i}

It is clear that alto it should be TodoApp.Todo.Item.todo_list_id for in the DB there is no such field as list_id but todo_list_id.

How to fix this?

From the docs at https://hexdocs.pm/ecto/Ecto.Schema.html#has_many/3:

:foreign_key - Sets the foreign key, this should map to a field on the other schema, defaults to the underscored name of the current schema suffixed by _id

So by default it will be “todo_list_id”, as that’s the schema name (I would actually expect todo_lists_id?). so you either need to change that “i.list_id” to “i.todo_list_id” in your query or else manually set what the primary key name is in your scheme to just be list_id … I would do the former, though, as then you don’t have to keep remembering to do this :slight_smile:

3 Likes

Well, thanks. Setting the foreign key solved the issue.
But then again, does this have anything to do with context for before i used the same code snippets in phoenix 1.2 with no problem.

Yeah, it just changed what the autogen’d schema name is … :slight_smile: