Call Phoenix function in command line

I would like to be able to call functions from my Elixir code while the whole Cowboy/Phoenix machinery is running. For some reason when I’m not on production everything works fine with iex -S mix. But on production I get

[error] Failed to start Ranch listener SyntaxWeb.Endpoint.HTTP in :ranch_tcp:listen([{:cacerts, :...}, {:key, :...}, {:cert, :...}, :inet6, {:port, 80}]) for reason :eaddrinuse (address already in use)

I’m not sure of what the problem is. From the error message, it seems that iex -S mix tries to listen port 80, while Cowboy is already listening to it. On the other hand it seems odd for the iex -S mix command to try running a server, does’n it ?

My question is : what is really happening ? and how can I load my project modules and run some elixir code in command line while a server is running on the machine ?

If this is Phoenix application, and you have:

config :phoenix, serve_endpoints: true

In your production configuration, then application will try to start application, and by extension - start listening -on application launch. And iex -S mix is the same as iex -S mix run, and mix help run returns:

                                    mix run

Starts the current application and runs code.

mix run can be used to start the current application dependencies, the
application itself, and optionally run some code in its context. For long
running systems, this is typically done with the --no-halt option:

    mix run --no-halt

Which mean it starts application which will fail due to trying to reuse listening port.

1 Like

But I do not have the line

config :phoenix, :serve_endpoints, true

neither in prod nor in dev. It is the same problem when I explicitly set server: false in the configuration file

I have no idea why the server does not start in my Dev env. I also don’t understand why putting server: false in the endpoint configuration keys seems to have no effect. I finally created another configuration which is the same than the production one, except that it does not start the endpoint (but it starts the Repo thing). This is configurable in the application.ex file.

Are you using releases? The server option has to do with them, otherwise if you are running the production system with mix it’s just your mix config.

If you are using releases and want to do something with the running system, check out the remote console:


Good call. I am using releases :slight_smile:, so that must be it.
I will check the link you provide


1 Like