Getting rid of ElixirLS alert "No mixfile found in project. To use a subdirectory..."

Screen Shot 2021-03-28 at 10.19.24 AM

How do I get rid of this alert once and for all, without creating mixfile or setting subdirectory?

Create a mix-file would be the obvious solution.

1 Like

you’re right, I was (implicitly) implying without a mixfile either. Updated the question

Do not edit single elixir files when the elixir-LS plugin is active.

Lol…

There is currently no way to disable it. The server emits the warning, the client displays it.

You can file an issue on the repo and ask for a setting that would disable emitting of the warning.

Over the past couple weeks I’ve been writing single-file Elixir scripts using the new Mix.install() feature in the Elixir 1.12 prerelease. (it works great!) I see the warning. A setting to disable the warning would be great. (see issue #518…)

2 Likes