Phoenix RuntimeError on FreeBSD 13.0 (couldn't fetch

Iam new to Phoenix Framework, I wanted to install it on my server which run FreeBSD 13.0, I have downloaded all requirements : PostgreSQL, NodeJS,…I have made my first hello project by doing mix phx.server and I got immediately an error :

** (RuntimeError) couldn't fetch
{:ok, {{'HTTP/1.1', 404, 'Not Found'},....

After some researches I discovered that tailwind is not supported yet as FreeBSD ready release, I tried to install it otherwise than that but I didn’t succeed so I decided to just ignoring it for the moment by removing it from mix.exs and config.exs but also I couldn’t because it seems that it is attached to Phoenix and I got always errors depending of it, so what should I do as FreeBSD user to go on with Phoenix ?

1 Like

Phoenix doesn’t depend on tailwind to work. If you’re still seeing errors you might have missed some of the handful of steps to remove the integration though. You can find a good summary of how to remove it here:


Maybe you could try installing the NPM version manually? The same problem exists with Dart Sass, there is no prebuilt binary available, but the NPM version works great (using it myself on FreeBSD).

1 Like


could you try these instructions from dch?

(thanks to him for porting tailwindcss-cli on FreeBSD - I use the binary he provides myself)

my server which run FreeBSD 13.0

FreeBSD 13.0 is EoL since 2022-08-31, you really should consider upgrading!

1 Like

@LostKobrakai Thank you I will try that for sure, but it seems that I should repeat lot of steps each time I create a new project

@zaljir Do you mean Node Package Manager ? because I have it already

@t0t0 I have followed some of this discussion tutorial, in specific this one but that didn’t work for me, can you give more details about right steps please ?

Besides the new core_components – which I hope we get community provided alternatives for other frameworks in the future – this is hardly different to what needed to be done in the past for ripping out what phoenix used to use in favor of tailwindcss or any other tooling not being the phoenix provided one. Phoenix doesn’t want to be involved in what you use as your assets pipeline, but given generators need to provide some UI there needs to be some default. The changes in 1.7 actually improve on that, as now generators don’t become useless the moment you’re no longer using their default css framework or setup.

1 Like

Yes! That one should provide an executable as well. I haven’t tried it myself though.

1 Like

Follow the instructions of the very last post of this issue (my link specifically pointed on it).

1 Like

Just editing mix.exs by adding the new URL without getting in details of this tag post?

Thanks a lot, it works perfectly now :ok_hand: